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Attendees  32 Members in 

attendance  
7 Online  via Net 
Meetings  

  Copied To  
  

LTUF Members    

   
Called By  John Dressel  Prepared By  John Dressel  
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m  

Topic  Notes  Action/
Due  

1  Welcome 
and 
Presentation  
 

• Gene Haney, CB&I Welcomed members of the Houston SmartPlant 
Instrumentation Local Technical Users Forum 

 

2  Chairman’s 
Notes  

• John Dressel Informed everyone that He would not be attending the 
SPI SPEL GTUF - August 29, 2010 due to scheduled surgery and 
that Gene Haney would chair the meeting in Las Vegas 

 
 Upcoming Conferences: 

 
SPI SPEL GTUF  -  August 29, 2010 
ARIA Resort at City-Center in Las Vegas 
 
Intergraph 2010  -  Aug. 30 – Sept. 2, 2010 
ARIA Resort at City-Center in Las Vegas 
 
Emerson Global Users Exchange - Sept. 27- Oct. 1, 2010 
Henry Gonzalez Convention Center, San Antonio, Texas 

3  Minutes   • Minutes of last meeting approved  
  

4  Introduction  • Each member stood and introduced themselves and their job 
functions with SPI 

•  Welcomed several members who connected into meeting with 
NetMeeting.     

 

  

5  Presentation  
  

SPI External Editor - John Dressel, Fluor  
  
• SPI External Editor  

• SmartPlant Instrumentation External Editor enables an external 
party (Vendor, contractor, engineering company, and so forth) to 
modify specifications outside of SmartPlant Instrumentation.  

• The External Editor allows the user to open specification sheets 
that have been created in SPI and modify them as needed.  

• The modified specification sheets can then be import back into 
SmartPlant Instrumentation for further processing.  

• The External Editor supports .psr and .isf file formats.  
• Using the External Editor, users may Edit a Single-Tag 

Specification or Edit a Multi-Tag Specification 
• The External Editor is a freeware program distributed by 

Intergraph 

  



• SmartPlant Instrumentation External Editor may be downloaded 
from: 
http://www.intergraph.com/products/ppm/smartplant/instrumentat
ion/external_editor_download.aspx 

 
• SPI Side of External Editor  

• Use of the External Editor starts within SPI 
• All Specs that need to be edited in the External Editor need to 

originate in SPI 
• Identify the Tag numbers that you wish to Edit externally and 

create a Spec sheet for each one 
• You may also create a multi-item spec sheet 

• The Tag number, Title block and Revision information cannot be 
edited with the External editor, so this data is the responsibility of 
the originator. 

• Be sure to select which fields you wish to edit in the External 
Editor in the Spec Data Dictionary 

• In the Spec Module select “Actions / Save as Files” then “Find” to 
select the Specs you wish to export 

• The ISF or PDF files will be placed in your SPI destination 
directory.  

 
• Using SPI External Editor 

• Edit a Single-Tag Specification  
1. On the File menu, click Open.  
2. From the Files of type list, do one of the following:  

Select Spec files (*.isf).  
Select .psr files.  

3. Navigate to the SmartPlant Instrumentation specification file that 
you want to edit, and click Open.  
4. Click inside each field that you want to edit and do one of the 
following, as available:  

Type a new entry, or edit the existing data.  
Select values from available lists.  
If necessary, you can add entries to the Manufacturers list and to 
the Model list, and include these in your specification.  

5. If you click the unit of measure fields, select values from the Select 
Unit of Measure dialog box that opens.  
6. On the File menu, do one of the following:  

Click Save. This option is available only if you loaded an .isf file.  
Click Save As, and in the dialog box that opens, change the 
existing file name or type a new name, and then click Save.  

• Notes  
The tag number field is never enabled for editing in External 
Editor.  
If you are editing a file with the older .psr suffix, the software 
automatically converts it to .isf format upon saving.  

 
• Edit a Multi-Tag Specification  

1. On the File menu, click Open.  
2. From the Files of type list, do one of the following:  
Select Spec files (*.isf).  
3. Navigate to the SmartPlant Instrumentation specification file that 
you want to edit, and click Open. 
4. Edit the numbered pages containing the fields that are identical for 
all of the tags. Click inside each field that you want to edit and do one 
of the following, as available:  

Type a new entry, or edit the existing data.  
Select values from available lists.  
If necessary, you can add entries to the Manufacturers list and to 
the Model list, and include these in your specification.  

5. If you click the unit of measure fields, select values from the Select 



Unit of Measure dialog box that opens. 
6. To edit the fields that differ from tag to tag, click the Multi-Item List 
tab. 
7. On the File menu, do one of the following:  

Click Save. This option is available only if you loaded an .isf file.  
Click Save As, and in the dialog box that opens, change the 
existing file name or type a new name, and then click Save.  

• Notes  
The tag number field is never enabled for editing in External 
Editor.  
If you are editing a file with the older .psr suffix, the software 
automatically converts it to .isf format upon saving.  

 
• Manufacturer and Model Tables 

• You can add and edit manufacturers and models to the 
Instrument Manufacturer and Instrument Model supporting 
tables.  

• These manufacturers and models are available when you edit 
specifications in External Editor.  

• When you open and then save an externally edited specification 
file in SmartPlant Instrumentation, the new manufacturers and 
models are added to the relevant supporting tables within 
SmartPlant Instrumentation.  

• To manage manufacturer and model tables, use the following 
procedures: 

 
• Add Manufacturers to the Instrument Manufacturer Table 

1. Open a specification file in External Editor. 
2. On the Edit menu, click Instrument Manufacturer. 
3. Click New. 
4. Under Manufacturer, type the name of the new manufacturer and 
click OK. 

 
• Edit Manufacturers in the Instrument Manufacturer Table  

1. Open a specification file in External Editor.  
2. On the Edit menu, click Instrument Manufacturer.  
3. Change the name of manufacturers that you want to edit, and click 
OK.  

 
• Delete Manufacturers in the Instrument Manufacturer Table  

1. Open a specification file in External Editor.  
2. On the Edit menu, click Instrument Manufacturer.  
3. In the data window, select the manufacturer that you want to 
delete, and click OK.  

 
• Add Models to an Instrument Model Table  

1. Open a specification file in External Editor.  
2. On the Edit menu, click Instrument Model.  
3. From the Manufacturer list, select the manufacturer of the model 
that you want to add.  
4. Click New.  
5. Under Model, type the name of the new model and click OK.  

 
• Edit Models in an Instrument Model Table  

1. Open a specification file in External Editor.  
2. On the Edit menu, click Instrument Model.  
3. From the Manufacturer list, select the manufacturer of the models 
that you want to edit.  
4. Change the name of models that you want to edit, and click OK.  

 
 
• Delete Models from an Instrument Model Table  



1. Open a specification file in External Editor.  
2. On the Edit menu, click Instrument Manufacturer.  
3. From the Manufacturer list, select the manufacturer of the model 
that you want to delete.  
4. In the data window, select the model that you want to delete, and 
click OK.  

 
• Convert a Batch of Specification Files PSR to ISF Format  

1. On the File menu, click Batch Conversion.  
2. In the Source folder text box, do one of the following:  
Type the path and name of the folder containing your source files.  
Click , and navigate to the folder.  
3. Do one of the following to set the target folder:  
Select Target folder same as source.  
Clear Target folder same as source, click , and navigate to the folder. 
4. Do one of the following to select the files that you want to convert 
to .isf format:  

In the data window, under Select, select the check box beside 
each file.  
To convert all of the displayed files, select the Select all check 
box.  

 
• Preferences Dialog Box  

• General Tab  
• Numeric field accuracy - Select a percentage value from this 

list to determine the level of accuracy for display of 
specification sheets.  

• Print ISF note page - Select to include note pages in 
specifications that you print from within External Editor - 
Clear to exclude note pages from the printing.  

• Enable translation - Select to allow an interface other than 
English. Select language - available if you selected Enable 
translation to Select an interface language. 

• Preferences Dialog Box  
• Mark Changes Tab  

• Mark changes — Select to mark changes in the current 
specification sheet. 

• Color — Marks changes on the screen, but not in printed 
reports. Select a predefined color or Custom. 

• Style — To display changes on the screen and in the 
printout, select Regular, Italic, Bold, or Bold Italic as the font 
style. 

• Example — Displays a sample sentence in the font style and 
color that you select. 

• Custom color — If in the Color box you selected Custom, 
these three spin boxes allow you to enter a value between 0 
and 255 for each of the primary colors. If you selected a 
predefined  

 
• External Editor Issues 

• The vendor spec sheets must be initially created by the GEC for 
export to the "External Editor Folder" and then to the vendor.  

• The External Editor software and user interface is not very user 
friendly requiring vendors to spend a lot of time populating the 
data onto each spec form. 

• The export and import of over Citrix is very time consuming 
usually requiring the manual delivery of files using CD or FTP 
transfer. 

• Revision control is handled manually by modifying the file names 
of the .isf files. 

• The use of the External Editor adds cost to the vendor that may 



not be included in their estimate or bid. 
• Printing of Spec Sheets is one at a time from within External 

Editor  
 
• External Editor Aids 

• When first distributing the "External Editor" software to a vendor, 
include a "readme.txt" file with installation and user instructions. 

• Give the vendor specific times as to when the files are to be 
returned to meet the project schedule. 

• Since vendor spec sheets can be repetitive, allow the vendor to 
populate one spec form and list the Tags that it applies to in 
notes. This will facilitate the data loading and import into 
SmartPlant Instrumentation. 

• Carefully select the fields in the Spec Module Data Dictionary 
(Spec DD) that will import into the SmartPlant Instrumentation 
database. 

• Return a copy of the completed SmartPlant Instrumentation spec 
forms to the vendor for approval before final issue. 

 
• SPI Side of External Editor  

• Use of the External Editor ends within SPI 
• Specs that are edited in the External Editor need to imported 

back into SPI 
• Specs may be imported to different Tag Numbers as long as the 

Spec Form is the same 
• The Tag number, Title block and Revision information cannot be 

edited with the External editor, so this data must be edited in SPI 
• Use caution when importing data and check the results carefully  

 
 

6  
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INAudit© & INSpec © Presentation  
by: Robert Cox, Overload Services, Inc.  

 
WiseTools Inc. 

• Developers of INAudit© a web based audit tool  
 for the SPI/INtools database. 

• Developers of INSpec a comprehensive SPI Spec/Datasheet 
auditing tool 

• Developers of Wise_SMA2PDF & Wise_PSR2PDF utilities to  
 automatically convert  SMART PLANT SMA and PSR files to  
 PDF files, running as a background service.  

• SPI/INtools consultants with 14 years experience  
 implementing SPI/INtools, data transfer, consulting, training and 
data entry. 

 
INAudit© Overview 

• Deliver a high quality database to your clients. 
• Incomplete and inaccurate data is a hidden cost both in 

engineering and plant maintenance. 
• Inaccurate and missing data is a safety risk. 
• A cost effective way to reduce this is with a versatile auditing 

program that can be customized to meet your standards. 
• Easy access to the SPI/INtools Plant, Area and Unit structure. 
• Audit at the Plant, Area or Unit level. 

 
• Main INAudit Modules window showing the High Level Filter 

  



configured for CWP (Construction Work Package Number.): 
Index, Datasheets, Process Data, Wiring, FF/PB Tags and 
Wiring, Loops, I/O, General Statistics, Standards 

Note:  
• The High Level Filter field is optional, can be any UDF or UDT. 

Example: Project Number, Module Number… 
• When a HLF value is entered only the related data will be 

audited 
 
Instrument Index Audit: Select any list option, example: Minimum Data 
Fields Report, Tags with Incorrect Service Descriptions… 
 
Index Initial Minimum Data Fields Report: Initial overall % complete and 
for each defined field. All List reports have an Export Data button to Excel 
 
Instrument Type Mismatch: Tag instrument types that are linked to a 
different instrument type in the database. 
 
Specification/Datasheet Audit Report 

• Tags without a Specification/Datasheet: The INAudit© 
administrator defines the instrument types with hard I/O that do 
NOT get assigned to a Specification/Datasheet as an exception 
list using the INAConfig utility 

 
Process Data Audit 

• Identify tags that are not assigned to the process module (i.e. 
have no Process Data) – select one Process Function or all. 

• Tags that are not assigned to the process module - have no 
Process Data. 

• Report Incomplete Process Data 
• You can export all the data reports to Excel. 

 
Wiring Audit Reports 

• Panel/Strip Reports Strips with Incomplete Revision Data 
• Incomplete Wiring Report by Loop Number 

 
Loop Audit Report 

• Loops with Measured Variable Mismatch 
 
I/O Audit Report 

• I/O Assigned by Type Report % Complete 
• I/O Detailed Report with Card % Free 

 
General Statistics Report 

• General Statistics (Domain) Report 
• Wiring General Statistics by Domain Control System (CS) Tags 

not Linked 
 
Standards Module - Checks for  changes, new or deletions to the 
standards 
 
 



INAConfig© - A utility used to configure the rules and exceptions for 
INAudit© when auditing your SPI database.  
 
INAudit© New FF/PB Module 

• FF/PB Index audit checking the SPI Instrument profiles for  CS 
tags defined 

• FF/PB Segment/Wiring Audits 
 
INSpec - New Spec/Datasheet auditing program 

• Define/Check instrument types assigned to spec forms for the 
audit  

Summary 
• INAudit© - Your 24hr/7days a week cost effective SPI/INtools 

administrator. 
• Improving the quality of your instrumentation database and 

reducing your project hand-over costs. 
 
Who’s Using the WiseTools Products? 

• Canadian Natural Resources 
• CDI  Engineering, Houston, USA 
• Chevron, Concord, CA, USA 
• Chevron, El Segundo, CA, USA 
• ExxonMobil, Houston, USA 
• Husky Energy, Canada 
• Hovensa, USA 
• Petro-Canada 
• Petrocon Arabia, Saudi Arabia 
• Petrobras, Brazil 
• Shell Canada 
• Shell International Exploration & Production, USA 
• Suncor Energy, Canada 
• Syncrude, Canada 
• Tesoro Companies, USA 

 
For further information Contact: 
WiseTools Inc. 
#306 – 605 1st Street SW 
Calgary, AB T2P 3S9 
Canada  
Phone: (403) 233-8015 Fax: (403) 233-8563 
Email: info@wisetools.ca Website: www.wisetools.ca
 

http://www.wisetools.ca/
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WISE_PSR2PDF & WISE_SMA2PDF Presentation  
by: Robert Cox, Overload Services, Inc.  
 
Designed to convert SmartPlant PSR & SMA files to PDF 
• WISE_PSR2PDF© and WISE_SMA2PDF© are scheduled 

desktop/server applications that automates the time consuming 
process of converting SmartPlant PSR and SMA files to a PDF 
equivalent. 

WISE_PSR2PDF© will… 
• Convert any Smart Plant Instrumentation (Datasheet Archive) PSR 

file to a PDF equivalent 
• Process ZIP files containing PSR file(s) 
• Process 2 or 3 page PSR datasheets archives into a single PDF file 
• Allow for multiple schedules to be run during the day or night 
• Allow for multiple source / destination folders to be serviced 
• Allow for the addition / modification of the Prefix / Suffix rules for the 

   generated PDF files 
• Creates a detailed log file 
• Auto check for new files added to the Source Folder  
• Auto check for modified files in the Source Folder 
• Define more than one schedule to automatically check for new or 

    modified files 
• Supports multiple services for multiple databases 
 
WISE_PSR2PDF Control Panel will provide... 
• Control over the WISE_PSR2PDF application via the Start/Stop and 

Run Now! Commands. 
• Quick input of the schedules you would like WISE_PSR2PDF to run 

during the day or night 
• Configuration of the Services (Source/Destination Folders) to be 

processed by WISE_PSR2PDF. 
• The ability to Add or Modify Prefix/Suffix rules to be used for each 

service. 
• Specification of the SPI/INtools RAD Engine (EXE) to be used. 
• Specification of the PDF Printing Utility to be used 
• Log File parsing functions for better analysis 
• Save feature for all Control Panel settings 
 
Requirements 
• .NET Framework 2.0 
• Windows 2000 / XP / Server 2003 
• A PDF printer driver. (Supported PDF printer drivers: PDF995, 

   DocuPrint, Bullzip, Adobe PDF Printer) 
• Adobe Reader 6.0 or higher 
• 1 GB of system RAM 
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Houston LTUF  
Owner/Operator Committee  
By Jim Federlein  
 
First meeting held October 6, 2009 at ISA Expo 
 
Now have: 
• 21 members  
• Representing 15 companies 
 
O/O Committee Members 
• Badiozzaman, Aarash, Pasadena Refining 
• Bensen, Mark, Honeywell Specialty Materials 
• Bielen, Frank, Bayer MaterialScience 
• Bryant, Alan, OXY Inc. 
• Brueckner, Greg, Bayer Technology Services 
• Drewnowski, Joe, BP 
• Federlein, Jim (Chair) 
• Fisk, Bret, Eli Lilly 
• Flory, Steve, Marathon Oil Company 
• Graham, Rick, ExxonMobil 
• Heckathorn, Tracy, BASF  
• Land, David, ConocoPhillips 
• Ed Limper, Bayer MaterialScience 
• Lovuola, Vic, Bayer Technology Services 
• Pollard, Fred, Syncrude 
• Sterling, Wayne, BASF  
• Thornton, Bernadette, ChevronTexaco 
• Virgillio, Quin, Bayer MaterialScience 
• White, Aimee, Air Products and Chemicals, Inc. 
• Wildey, Sharon, GE Infra Aviation 
• Koifman, Alex, Intergraph 
• Kunev, Andrew, Honeywell Automation and Control Solutions 
 
Meetings held every 2 months via teleconference: 
• May 25 – SPI-SAP Interface presented by David Land of 

ConocoPhillips 
• July 27 – Claiming/Merging and Plant/Area/Unit Structure presented 

by Greg Brueckner of Bayer Technology Services 
 
O/O Topics of Member Interest 
• SPI Maintenance & Calibration Modules – Who is using? In what 

capacity? Is the maintenance module sufficient for I&E Maintenance 
needs? Anyone used the Fluke interface? 

• How to police contractors from changing plant standards. 
• Internal I.T. SPI System & Admin Support (with SPI expertise) for 

O/O 
• Tips & Tricks for Internal SPI Networks (eg.  Citrix)  
• Integration with Maintenance Management System(s)  
• Integration issues/gaps with other Systems (DCS Systems, Device 

Network Systems)  
• Best Practices for SPI Hierarchy  
• How to make SPI information available through other applications 

(e.g. Documentation, Sharepoint). 
• Upgrading (versions, service packs, hot fixes) 
• Archiving of revisions. 
 
 
 
 

  



Next meeting: 
• September 21, 10 AM – Noon EDT  
• Instrument Specification Forms with presentations by:  

o Rick Graham of ExxonMobile 
o Bret Fisk of Eli Lilly 
o Jim Federlein of Bayer Technology Services 

 
Anyone interested in joining the O/O committee should contact: 
• Jim Federlein @ jimf@federlein.eng.pro 
• John Dressel @ John.Dressel@fluor.com 
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SPI TUF Websites Report 
By:  John Dressel 
 
CR Ranking Website 
• Connection to the CR Ranking website via: 

http://www.sptuf.com/ or http://www.spi-ltuf.org/ 
• This site is designed to enable the Intergraph® User Community to 

put forward Change Requests (CR's). Once a CR has been 
submitted, it undergoes peer review by the entire user community. 
Intergraph® will provide responses to all highly Ranked CR's. 

• The website also hosts Meeting Minutes, if your LTUF does not have 
a website and would like to publish the Meeting Minutes via the Web 
contact: 
Dennis Cooley 
CooleyCore Associates Inc. 
Cell: (403) 975-9797 
Dennis.Cooley@CooleyCore.com
 

Home Screen 
• Core Areas 
• Header Navigation Menu  
• Links to: 
• Intergraph 
• Houston LTUF 
• UK User community 
• Month's Top 5 Change Requests  
• Intergraph's Latest Change Request Commitments 
 
My Profile 
• After a User logs in – They have access to the work preferences 

screen   
 
Take The Vote 
• Ranking Area 
• Navigate from CR to CR  
• Rank CR with “Your Opinion:”  
• View associated Documents 
• Join a Discussion Forum on each CR 
• Submit Your Comment or Ranking   

 

mailto:jimf@federlein.eng.pro
mailto:John.Dressel@fluor.com
http://www.sptuf.com/
http://www.spi-ltuf.org/
mailto:Dennis.Cooley@CooleyCore.com


 
 
Printable Summary 
• This allows the users to print out a summery filtered on their 

preferences   
 
Modify Preferences 
• This allows the users change their viewing preferences   
 
Add your CR 
• Users may add their own valid CR to the ranking database. 
• Enter a CR Number 
• Enter a SR Number (Optional) 
• Enter a description of the CR  
• Associate a Document to a CR 
• Select SPI or SPEL 
• Place additional Comments   
 
• The Houston SPI LTUF Website has a link to the CR Ranking 

Website   
• The Houston SPI LTUF Website has a link to the Houston SPI LTUF 

Newsletter 
• The Houston SPI LTUF Website has a link to the Houston SPEL 

LTUF Website 
 
 

10 Forum 
Topics 

The following topics were discussed or surveyed from the attendee: 
• Houston LTUF Workshops  
• SmartPlant Foundation  
• External Editors  
 

 

11  Close  - Next meeting will be held on:  November 11, 2010 
- John Dressel closed meeting  

 

  

 
  
 
  


