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SPI External Editor

+ SmartPlant Instrumentation External Editor enables an external
party (Vendor, contractor, engineering company, and so forth) to
modify specifications outside of SmartPlant Instrumentation.

+ The External Editor allows the user to open specification sheets that
have been created in SPI and modify them as needed.

+ The modified specification sheets can then be import back into
SmartPlant Instrumentation for further processing.

+ The External Editor supports .psr and .isf file formats.

+ Using the External Editor, users may Edit a Single-Tag Specification
or Edit a Multi-Tag Specification

+ The External Editor is a freeware program distributed by Intergraph
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SPI External Editor Download

+ SmartPlant Instrumentation External Editor may be downloaded from:
http://www.intergraph.com/products/ppm/smartplant/instrumentation/external_editor _download.aspx

INTERGRAPH'

4 Bag
SmartPlant® Instrumentation Powered by INtools®
External Editor Download

- PP&M Solutions
- Industries

- Enterprise So
Download External Editor for SmariPlant Instrumentation from the following locations:
Please note that you cannot open .ISF files generated by SPI 2009 or updated by External Editor

2009 with External Editor 2007 or earlier version. Please make sure you are using the appropriate
version of External Editor matching your target SPI version

External Editor 2009

Please note that if you open and modify ISF file generated by SP1 2007 or updated by External
Editor 2007 in External Editor 2009 you will not be able to imponrt that file into SP1 2007 or External
Editor 2007. Please make sure you are using appropriate version of External Editor matching your
target SPlversion

External Editor version 2009 SP1 (09.00.01.0117)

{ Site D@ (U.S)
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SPI Side of External Editor

¢ Use of the External Editor starts within SPI

¢ All Specs that need to be edited in the External Editor need to
originate in SPI

+ ldentify the Tag numbers that you wish to Edit externally and
create a Spec sheet for each one

— You may also create a multi-item spec sheet

¢ The Tag number, Title block and Revision information cannot
be edited with the External editor, so this data is the
responsibility of the originator.

E SmartPlant Instrumentation
File Maodules Edit | Actions Reparts Options  Framework  Tools  Window

ﬁ @ Chrl+I

” Clase  Sen. Reports

Open Entity Specification. ..

Save as Excel...

E Specifications et Bsiiel
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SPI External Editor

¢ Be sure to select which fields you wish to edit in the External
Editor in the Spec Data Dictionary

Field Properties | Tables | URL Sting |

b
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SPI External Editor

¢ Inthe Spec Module select “Actions / Save as Files” then “Find”
to select the Specs you wish to export

¢ The ISF or PDF files will be placed in your SPI destination
directory.

x

T arget folder:

|E:'xF'r|:|gram FilezhSmartPlantnstrumentation’, Browsze. ..

v ISF

Select file format
|7 " PSH

Frogress:

Achivity:

o | cancal | End. | Hep |
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Using SPI External Editor

+ Edit a Single-Tag Specification
1. On the File menu, click Open.

2. From the Files of type list, do one of the following:
» Select Spec files (*.isf).
* Select .psr files.

3. Navigate to the SmartPlant Instrumentation specification file
that you want to edit, and click Open.

4. Click inside each field that you want to edit and do one of the
following, as available:
 Type a new entry, or edit the existing data.
» Select values from available lists.

* If necessary, you can add entries to the Manufacturers list
and to the Model list, and include these in your
specification.
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Using SPI External Editor

+ Edit a Single-Tag Specification

5. If you click the unit of measure fields, select values from the
Select Unit of Measure dialog box that opens.

6. On the File menu, do one of the following:

e Click Save. This option is available only if you loaded an .isf
file.

* Click Save As, and in the dialog box that opens, change the
existing file name or type a new name, and then click Save.

¢ Notes

— The tag number field is never enabled for editing in External
Editor.

— If you are editing a file with the older .psr suffix, the software
automatically converts it to .isf format upon saving.
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Using SPI External Editor

+ Edit a Single-Tag Specification

File Edit ‘Window Help
ERAIEEIE R
[5) Page 1 | ZNates |
1 | Tag Mumber A1-PT -310037
2| Service SUMP PUMP DISCH
3 | Location PEID 11-J-31003
GEMERAL 4 | Function Line Mo 361061
5 | Mounting
6 | Area Classification
7 | Certification
& | Enclosure HEMA ¥
9| Ambient Tempersture -20°F to 115 F
10| Fluid State Licquict
PROCESS 11 | Pressure Max. Oper. 60 pi-g 30 pEi-g
COMNDITIONS 12 | Temperature Max. Oper. 120 °F &0 °F
13| Oper. Spec. Gravity | Oper. Viscosity =
14 | Design Pressure Design Temperature
15 | Minimum Design Temperature
16 | Instrument Range Min. | WMax. 1] psi 200 psi
17 | Calibration Range Min. | Wax. 1] psi 60 psi
18 | Elewation Suppression i, IS
19 | Elemernt Type Powver Supply capsule 12 to 30 vDC
20 | Elemert Material Hastelloy C-276
TRAMSMITTER: |21 | Body Material | Body Rating SUS 3M6L
22 | Process Flange Material SUS 3M6L
23 | Wetted O-Ring WMaterial Teflon PTFE
24 | Fill Fluid Cutput Silicone il 4-20 ma
25 | Boks Housing nia Low Copper Cast Aluminum
26 | Pairit Tx Failure Mode Polyethane Up Scale
27 | Process Connection | Electrical Connection | 1/2" HPT {F) 1.2 HPT {F)
25 | Flow Rate Load Resistance
29 | Allowwable Temp. ez, Static Pressure | -40 to 140 °F 600 psi
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Using SPI External Editor

+ Edit a Multi-Tag Specification
1. On the File menu, click Open.

2. From the Files of type list, do one of the following:
» Select Spec files (*.isf).

3. Navigate to the SmartPlant Instrumentation specification file
that you want to edit, and click Open.

4. Edit the numbered pages containing the fields that are
identical for all of the tags. Click inside each field that you
want to edit and do one of the following, as available:

 Type a new entry, or edit the existing data.
» Select values from available lists.

* If necessary, you can add entries to the Manufacturers list
and to the Model list, and include these in your
specification.
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Using SPI External Editor

+ Edit a Multi-ltem Specification

5. If you click the unit of measure fields, select values from the
Select Unit of Measure dialog box that opens.

6. To edit the fields that differ from tag to tag, click the Multi-ltem
List tab.

7. On the File menu, do one of the following:

« Click Save. This option is available only if you loaded an .isf
file.

* Click Save As, and in the dialog box that opens, change the
existing file name or type a new name, and then click Save.

¢ Notes

— The tag number field is never enabled for editing in External
Editor.

— If you are editing a file with the older .psr suffix, the software
automatically converts it to .isf format upon saving.
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Using SPI External Editor

+ Edit a Multi-Tag Specification

E’ External Editor

File Edit ‘Window Help
ERAIECIEIRE TS
(5] Page 1 | & Multi-lkem Listl 2| MNotes |

1| Tag MNumber SEE LIST[11-Pl -300001]
2| Service SEELIST
GEMERAL 3 | Location INSTRUMEHNT AIR SYSTEM
4| PEID
5 | Line MNumker Equipment
E | Fluid Phaze Gazivapor
7 | Max. Pressure Mz, Temperature SEE LIST SEELIST 200 °F
PROCESS & | Oper. Pressure Oper. Temperature SEE LIST a0 °F
COMDITIONS 9 | Pulzation “ibration
10| Design Pressure Design Temp 300 psi-g 200 °F
11
12 | Type
13 | Calibration Range Min. [Ma. 50 psi g [0 psi g
14 | Figure—t=s =
15 hino
16 |Mouny File Edit ‘Window Help
17 | Dial J ,h
18 | Dial HE ‘ [ Hﬁ Hlélﬁ‘iﬂ
19 | Cazel "
caUGE 20[Ring
21 [Bow] | 5] Page 1 aMum-uemList|@NDtes |
22 | Lenz
23 | Pres Tag Mumkber General Service Max. Pressure  Oper, Pressure pdd_p_dif_press_
24 {Presy | 111 -3000m 185 HEADER 300 75 psi
11-Pl -300002 |&= HEADER 300 73 =)
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Using SPI External Editor

¢ Manufacturer and Model Tables

— You can add and edit manufacturers and models to the
Instrument Manufacturer and Instrument Model supporting
tables.

— These manufacturers and models are available when you edit
specifications in External Editor.

— When you open and then save an externally edited
specification file in SmartPlant Instrumentation, the new
manufacturers and models are added to the relevant
supporting tables within SmartPlant Instrumentation.

— To manage manufacturer and model tables, use the following
procedures:
* Add Manufacturers to the Instrument Manufacturer Table
» Edit Manufacturers in the Instrument Manufacturer Table
» Delete Manufacturers in the Instrument Manufacturer Table
* Add Models to an Instrument Model Table
» Edit Models in an Instrument Model Table
* Delete Models from an Instrument Model Table
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Using SPI External Editor

¢ Add Manufacturers to the Instrument Manufacturer Table
1. Open a specification file in External Editor.
2. On the Edit menu, click Instrument Manufacturer.
3. Click New.

4. Under Manufacturer, type the name of the new manufacturer
and click OK.

E Instrument Manufackur

tanutacturer
APPLETOMN
ARMSTRONG
ASCO
ASHCROFT

Ll

ASHCROFT - DURATEMP

ASO Safety Solutions

ATORMAL

AUBURM SYSTEMS LLC -

1| |

(] I Cancel Mew elete | Help |
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Using SPI External Editor

¢ Edit Manufacturers in the Instrument Manufacturer Table
1. Open a specification file in External Editor.
2. On the Edit menu, click Instrument Manufacturer.

3. Change the name of manufacturers that you want to edit, and
click OK.

E Instrument Manufackur

tanutacturer
APPLETOMN
ARMSTRONG
ASCO

Ll

ASHCROFT
ASHCROFT - DURATEMP

ASO Safety Solutions
ATORMAL
AUBURM SYSTEMS LLC -

1| |

(] I Cancel Mew elete | Help |
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Using SPI External Editor

¢ Delete Manufacturers in the Instrument Manufacturer Table
1. Open a specification file in External Editor.
2. On the Edit menu, click Instrument Manufacturer.

3. In the data window, select the manufacturer that you want to
delete, and click OK.

E Instrument Manufackur

tanutacturer
APPLETOMN
ARMSTRONG
ASCO

Ll

ASHCROFT
ASHCROFT - DURATEMP

ASO Safety Solutions
ATORMAL
AUBURM SYSTEMS LLC -

1| |

(] I Cancel Mew elete | Help |
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Using SPI External Editor

¢ Add Models to an Instrument Model Table
1. Open a specification file in External Editor.
2. On the Edit menu, click Instrument Model.

3. From the Manufacturer list, select the manufacturer of the
model that you want to add.

4. Click New.
5. Under Model, type the name of the new model and click OK.

x

M anufacturer: IASHCHDFT j

b odel -

10-6503-5-5-02L -5 M5 G HMLMH+C4-<C6-<6B < C01-0/5 pzid
1950-0-2F

21000 240F 4250008,

25-10095%/-028-C0 4-1004

25-10035%/-02B8-C0 4-154

25-1009-5'-L-028

28-1003-5Ww-L-02E / 25-10155-02T-CE
28-H-PGG-4-F4-SFL-L kL +MH-»Cd-<CE-+CO1-4000% _lll
4 [ >

QK I Cancel Hew Delete | Help |
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Using SPI External Editor

¢ Edit Models in an Instrument Model Table
1. Open a specification file in External Editor.
2. On the Edit menu, click Instrument Model.

3. From the Manufacturer list, select the manufacturer of the
models that you want to edit.

4. Change the name of models that you want to edit, and click
OK.

x

M anufacturer: IASHCHDFT j

b odel -

10-6503-5-5-02L -5 M5 G HMLMH+C4-<C6-<6B < C01-0/5 pzid
1950-0-2F

21000 240F 4250008,

25-10095%/-028-C0 4-1004

25-10035%/-02B8-C0 4-154

25-1009-5'-L-028

28-1003-5Ww-L-02E / 25-10155-02T-CE
28-H-PGG-4-F4-SFL-L kL +MH-»Cd-<CE-+CO1-4000% _lll
4 [ >

QK I Cancel Hew Delete | Help |
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Using SPI External Editor

¢ Delete Models from an Instrument Model Table
1. Open a specification file in External Editor.
2. On the Edit menu, click Instrument Manufacturer.

3. From the Manufacturer list, select the manufacturer of the
model that you want to delete.

4. In the data window, select the model that you want to delete,
and click OK.

x

M anufacturer: IASHCHDFT j

b odel -

10-6503-5-5-02L -5 M5 G HMLMH+C4-<C6-<6B < C01-0/5 pzid
1950-0-2F

21000 240F 4250008,

25-10095%/-028-C0 4-1004

25-10035%/-02B8-C0 4-154

25-1009-5'-L-028

25-1009-Sw/-L-02B / 25-10155-02T-C6

25-H-PGG-4-F--SFL-L-#ML-MNH-<C4-=Ch-xC01-400048 -
| _>I_I

4]
QK I Cancel Hew Delete | Help |
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Using SPI External Editor

¢ Printing from External Editor

+ A number of options are available for printing specification
sheets using External Editor.

— Print Individual Specification Sheets

* You can print specification sheets from External Editor one at a

time.
> On the File menu, click Print
— Print Specification Sheets Without Notes

* You can print specification sheets without printing the
accompanying note pages.

e 1. On the File menu, click Preferences.

e 2.0n the General tab, clear Print ISF note page.

« 3. Do one of the following:
> Print a specification from External Editor.
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Using SPI External Editor

o Convert a Batch of Specification Files PSR to ISF Format
— 1. On the File menu, click Batch Conversion.

— 2. Inthe Source folder text box, do one of the following:

* Type the path and name of the folder containing your source
files.

* Click , and navigate to the folder.

— 3. Do one of the following to set the target folder:
» Select Target folder same as source.
» Clear Target folder same as source, click , and navigate to the
folder.
— 4. Do one of the following to select the files that you want to
convert to .isf format:

* |n the data window, under Select, select the check box beside
each file.

* To convert all of the displayed files, select the Select all check
box.

SmartPlant’
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Using SPI External Editor

¢ Convert a Batch of Specification Files PSR to ISF Format

Batch Conversion

x|

— Source filez
Source folder

Il:: “Program Filesh S martPlantsnztrumentation\External Editor

L

Select |Fi|e M arne

11 -310134-PAGET.PSR
11 -310135-PAGET.PSRA
11 32001 2-PAGET.PSA
TR -320101-PAGET.PSR
1R -320102-PAGET.PSR
1R -320103-PAGET.PSR
11 -320104-PAGET.PSR
11 -320105-PAGET.PSA
1R -320106-PAGET.PSR
1R -320107-PAGET.PSR
11 -320108-PAGET.PSR
1R -320110-PAGET.PSR

T RIRR AR R R R R

[ Select Al

— Tarqget files
Target folder

|E: “Program Filez\SmartPlantsnstrumentationsE xternal E ditor

v Target folder same as source
[~ Devenwrite target files without prompting

[ o |

Cancel |

Help

FLUOR.
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Using SPI External Editor

¢ Preferences Dialog Box
— General Tab

 Numeric field accuracy - Select a
percentage value from this list to

= determine the level of accuracy for
General | Mk Changes | display of specification sheets.
ﬂ%@mw * Print ISF note page - Select to include
note pages in specifications that you
B it 17 eto pee print from within External Editor - Clear
| e erelter to exclude note pages from the printing.
aemen T  Enable translation - Select to allow an

interface other than English. Select
language - available if you selected
Enable translation to Select an
interface language.

SmartPlant’
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Using SPI External Editor

o Preferences Dialog Box
— Mark Changes Tab

—  Mark changes — Select to mark changes in

the current specification sheet.
General Mark Ehange&l

e Color — Marks changes on the screen, but

':lma”“ el " not in printed reports. Select a predefined color
Laolor: e
[Fed =] [6oe =l or Custom.
S « Style — To display changes on the screen and
[This is an example of a changed t in the printout, select Regular, Italic, Bold, or

Custorn Calar Bold Italic as the font Style .

?d B :I « Example — Displays a sample sentence in the

;EE” |—IE§ font style and color that you select.

- : « Custom color — If in the Color box you

- e i selected Custom, these three spin boxes
ance Help

allow you to enter a value between 0 and 255
for each of the primary colors. If you selected a
predefined

SmartPlant’
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Using SPI External Editor

¢ External Editor Issues

— The vendor spec sheets must be initially created by the GEC for
export to the "External Editor Folder" and then to the vendor.

— The External Editor software and user interface is not very user

friendly requiring vendors to spend a lot of time populating the
data onto each spec form.

— The export and import of over Citrix is very time consuming
usually requiring the manual delivery of files using CD or FTP
transfer.

— Revision control is handled manually by modifying the file names
of the .isf files.

— The use of the External Editor adds cost to the vendor that may
not be included in their estimate or bid.

— Printing of Spec Sheets is one at a time from within External
Editor

FLUO R® SmartPlant’
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Using SPI External Editor

¢ External Editor Aids

When first distributing the "External Editor" software to a vendor,
Include a "readme.txt" file with installation and user instructions.

Give the vendor specific times as to when the files are to be
returned to meet the project schedule.

Since vendor spec sheets can be repetitive, allow the vendor to
populate one spec form and list the Tags that it applies to in
notes. This will facilitate the data loading and import into
SmartPlant Instrumentation.

Carefully select the fields in the Spec Module Data Dictionary
(Spec DD) that will import into the SmartPlant Instrumentation
database.

Return a copy of the completed SmartPlant Instrumentation spec
forms to the vendor for approval before final issue.

SmartPlant’
F L U O R® T /nstrumentation



SPI Side of External Editor

¢ Use of the External Editor ends within SPI

¢ Specs that are edited in the External Editor need to imported
back into SPI

¢ Specs may be imported to different Tag Numbers as long as the
Spec Form is the same

¢ The Tag number, Title block and Revision information cannot be
edited with the External editor, so this data must be edited in SPI

¢ Use caution when importing data and check the results carefully

SmartPlant’
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SPI External Editor

¢ Questions?

FL u o R By: John Dressel - FLUOR

AV\filename.ppt 28
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